Some investigations delayed on subset of environments

Incident Report for Dropzone AI

Resolved

The fix has been rolled out to all environments, delayed alerts are being processed, and all systems are now operating normally.
Posted Jun 23, 2026 - 15:38 PDT

Identified

Dropzone has identified a drop in alert processing across 5% of customer environments. For those affected, alerts which were ingested during daily system updates were stuck in a pending state and were not investigated. A fix is in progress, and will automatically start those delayed investigations.
Posted Jun 23, 2026 - 14:55 PDT
This incident affected: Dropzone Instances.